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Satellite Data & GIS Training

• Uses ESRI ArcGIS Pro, but techniques generally work with 
QGIS and other GIS software
• ESRI has moved away from support for ArcMap
• Using ArcGIS will generally require a license 

• Updated from CoastWatch Satellite GIS training in 2021
• EDC tool, developed for ArcMap, is not available for ArcGIS Pro

• This training was created using ArcGIS Pro 3.3.2

• The current version of ArcGIS Pro is 3.6 (+)
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Data
Using Satellite Data in GIS
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Overview

● Imagery

● Data

● Considerations and 
preparations

S-NPP VIIRS SST Image
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Satellite Imagery

● Visualization

● Scaled data

● Formats
○ PNG, JPEG, 

GeoTIFF

S-NPP VIIRS True Color Imagery
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8-bit Image Example

8-bit (0-255) image of Sea Surface Temperature stored in GeoTIFF

186          191          228      

102          153         142        

94            126          106     
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Satellite Data

● Calculations

● Values

● Formats
○ HDF, NetCDF, 32-

bit GeoTIFF

S-NPP VIIRS Chlorophyll-a Science Quality

5.31
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Data Considerations

● Metadata

● Format

● Resolution

● Projection
○ Coordinate system
○ Datum

● Preparation
NOAA Blended SST in North Polar Stereographic Projection
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Metadata

• Information about the data – usually standardized

• Methods used in collection / processing

• Custodian / Point-of-contact
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Data Formats

• Level of embedded metadata – ‘self-describing’

• Data storage
• Scaling / Offset
• Compression

• Geolocation Information
• Tags
• Attributes

• Complexity and Compatibility

NetCDF
TIFF

HDF

GeoTIFF

JPEG
CSV
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Product Resolution

• Spatial resolutions
• meters to hundreds of kilometers

• Temporal resolutions
• minutes to days, weeks, or months

• How are data combined?

Resolutions from various 
chlorophyll-a products
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Projections

• Satellite sensor view (Swath / Level-2)
• Irregularly/nonlinearly spaced
• May include unique structure based on sensor
• Geolocations with respect to Ellipsoid and Datum

• Mapped (Gridded / Level-3, -4)
• Coordinate system
• Locations with respect to Ellipsoid and Datum
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Projections

• Coordinate Systems
• Projection constructs
• Preserves one of the following 

(not all are listed):
• Conformality (Shape)
• Area
• Direction
• Distance

• Chosen based on application/scale

• Spatial distortion results from mapping

Cylindrical

Azimuthal

Map construct types
(not all are shown)
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Geographic (WGS84)

Tissot’s indicatrix of circles illustrating distortion across a mapProjection Plane

Earth’s
Surface
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Mercator (WGS84)       GOES-16 (GRS80)            Azimuthal 
Equidistant

Tissot’s indicatrix of circles illustrating distortion across a map
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Projections -
Conformality 

● Shape is preserved
● Representative of 

actual feature
● Useful for preserving 

shape
● Lambert Conformal 

Conic
● Mercator

○ Straight lines have 
constant bearing

Lambert Conformal Conic preserves shape
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Projections -
Area

● Area is preserved

● Area measurements 
consistent across map

● Useful for comparison

Albers Equal-area preserves area
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Data Preparations

● Reprojection 
required?

● Metadata complete?

● Values accessible?

● Compositing or 
binning required?
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Summary

● Imagery

● Data

● Considerations and 
preparations

S-NPP VIIRS SST Image
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GIS
Using Satellite Data in GIS
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Overview

● Tools & methods

● ArcGIS built-ins & add-
ons 

● External utilities
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• ArcGIS Spatial Analyst (license) – ESRI
• Raster tools

• CoastWatch Utilities
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html

• Read data files (NetCDF and HDF format)
• Graphical tools for interactive data viewing 
• Command line tools for data processing

• cwexport, cwsample, cwrender

Useful Extensions / Add-ons

https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
https://coastwatch.noaa.gov/cwn/data-access-tools/coastwatch-utilities.html
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• WMS and WCS

• Drag-n-drop 
• GeoTIFF, HDF, NetCDF, JPEG2000

• Multidimension Toolbox
• Make OpenDAP Raster Layer 

(Geoprocessing → Multidimensional Tools)
• Make NetCDF Raster Layer 

(Geoprocessing → Multidimensional Tools)

• Programmatically
• Python, Jupyter Notebooks

Methods to add Satellite Data
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Web Mapping and Coverage Services (WMS and WCS)

• Add data locally

• WMS: image

• WCS: data values

• Things to note:
• OK for single time/place

• Can be frustrating on finding the correct URL

• Each change in PZI results in refresh call

• And sometimes… 
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…errors
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• Quick and easy

• Requires configuration
• Symbology
• NetCDF
• Time/Time slider

• Things to note:
• Defaults to first variable
• Don’t always get what you want

Drag-n-Drop
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• A few clicks
• Menu-driven configuration 

to maximize usefulness
• Handles file or aggregates

• Enter URL without extension
• Requires additional configuration 

to maximize usefulness

• Things to note:
• Unexpected Errors
• Results may vary

Make OpenDAP Raster Layer
Analysis → Geoprocessing → Multidimension Tools →
Make OpenDAP Raster Layer
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• A few clicks

• Menu-driven configuration 
to maximize usefulness

• Requires configuration
• time, time slider

Make NetCDF Raster Layer
Analysis → Geoprocessing → Multidimension Tools →
NetCDF → Make NetCDF Raster Layer
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• Format raster layer appearance
• Color scheme / invert
• Edit min/max values / classes

• Right-Click Layer → Symbology

– OR –

• Raster Layer → Symbology

• Menu-driven configuration 
to maximize usefulness

Layer Properties: Symbology
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• Format raster layer appearance
• Time extent / interval / step

• Right-Click Layer → Properties

– OR –

• Raster Layer → Multidimensional

• Menu-driven configuration 
to maximize usefulness

Layer Properties: Time
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Enable Time Slider

• And sometimes… ERRORS!
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• Right-Click Layer → Data →
Export Raster

• Input general settings
• Output Raster Dataset
• Output Format
• …and more

• Click “Export”

Export Data to Geospatial Database
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Recap Methods to add Satellite Data

• Add Data
• Multidimensional Data… 
• From Path… 
• Browse… 

• Analysis → Geoprocessing →
Multidimension Tools →
• Make OPeNDAP Raster Layer
• NetCDF → Make NetCDF 

Raster Layer

• Drag-n-Drop and EDC no longer recommended 
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• OpenDAP

• THREDDS

• ERDDAP

Additional Services to Obtain Data

Example of THREDDS Catalog
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OpenDAP (Open Data Access Protocol)

Example of Dataset Descriptor Structure

• Data model

• Application Program Interface (API)

• Dataset Descriptor Structure (DDS)
https://coastwatch.noaa.gov/erddap/griddap/noaa
cwBLENDEDsstDaily.dds

• Dataset Attribute Structure (DAS)
https://coastwatch.noaa.gov/erddap/griddap/noaa
cwBLENDEDsstDaily.das

• Used within THREDDS / ERDDAP

https://coastwatch.noaa.gov/erddap/griddap/noaacwBLENDEDsstDaily.dds
https://coastwatch.noaa.gov/erddap/griddap/noaacwBLENDEDsstDaily.dds
https://coastwatch.noaa.gov/erddap/griddap/noaacwBLENDEDsstDaily.das
https://coastwatch.noaa.gov/erddap/griddap/noaacwBLENDEDsstDaily.das
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• Provide additional means to obtain data

• Temporal and spatial subsetting

• Useful services
• OpenDAP (THREDDS)
• NetCDF Subset Service (THREDDS)
• GRIDDAP (ERDDAP)
• TableDAP (ERDDAP)

THREDDS and ERDDAP

ERDDAP (GRIDDAP) Data Access Form
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Things To Note… 

• Data Units
• SST may come in Kelvin or degrees Celsius (rarely Fahrenheit)
• Chl comes in several units  that do not necessarily change the values

• Time
• Check the time zones for data – likely UTC

• Dateline
• Most satellite data composited daily products and may span 180W-180E
• May introduce a mismatch in data collection time across the dateline

• Projection / Map Units
• Note units as usually the first data loaded sets projection and units
• Ellipsoids/Datum – satellite data is most likely WGS84, land/coastal data 

may be NAD83
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Additional ESRI Resources

• ArcGIS Pro quick-start tutorials 
• introduces you to many aspects of ArcGIS Pro
• https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-

tutorials.htm

• ArcGIS Pro Basics WebCourse
• introduces you to the powerful capabilities of ArcGIS Pro and how to 

integrate, visualize, analyze, and share your data
• https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/

arcgis-pro-basics/

• ArcGIS Pro Resources
• build your expertise through documentation, tutorials, and more
• https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources

https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://pro.arcgis.com/en/pro-app/latest/get-started/pro-quickstart-tutorials.htm
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/training/catalog/5cad02469b1f4010cad9ac46/arcgis-pro-basics/
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources
https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources


NOAA CoastWatch/PacIOOS Satellite and Ocean Data Training Course | https://coastwatch.noaa.gov          40

Questions?
Using Satellite Data in GIS
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